Korax Mail Server - Login issues Wednesday 15th September 2021 17:30:00


FIXED: Sep/15/2021 07:40 PM EST

Our Server Admins have fixed the issue. The mail server and login via email client and webmail should be working normally at this time. If you are still experiencing any issue, please feel free to contact us via our Support channels.


INVESTIGATING: 15/09/2021 5:40 PM EST

The Korax mail server is currently experiencing issues with SMTP services which may result in disconnection and inability to login via email client as well as webmail. Our Server Administrators are investigating into this issue and working to resolve it as quickly as possible. Further updates will be posted here as available.