Emails not being delivered - cPanel email accounts Thursday 29th July 2021 08:30:00


FIXED:

The issue has been resolved and email delivery should already be working fine.

We apologize for the inconvenience that you have experienced.


UPDATE: August 04, 2021 01:30 AM EST

Our Server Admins are working non-stop to resolve the cause of the issue. We will provide more updates as they are made available.

We sincerely apologize for the inconvenience caused.


UPDATE: August, 02, 2021 1:00 PM EST

Our Server Admins are still working to fix the cause of the emails not being delivered. We will provide more updates as they are made available.

We sincerely apologize for the inconvenience caused.


UPDATE: July 30, 2021 1:00 AM EST

Our Server Admins are working to fix the cause of the emails not being delivered as soon as possible. We will provide more updates as they are made available.

We sincerely apologize for the inconvenience caused.


INVESTIGATING: July/29/2021 08:30 AM EST

A small amount of clients are experiencing issues where emails are not being delivered from cPanel email accounts.

Our server side engineers are investigating this and further updates will be posted here.

We appreciate your patience while the issue is being investigated.