Basic/Advanced Email Issue Monday 7th June 2021 15:00:00


RESOLVED: 07:00 PM EST

Our team has conducted backend migrations to mitigate the delays. Email delivery should be back to normal now.

We appreciate your patience and we apologize for the inconvenience caused.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket. You can find all our contact info at www.hostpapa.com.


IDENTIFIED: 3:00 PM EST

We are experiencing issues with basic/advanced emails. This will result in some delays in email delivery. Our team is already investigating the issue.

We will provide an update once we have additional information. We are sorry for the inconvenience that this might cause you.