Basic/Advanced Email Issue Friday 4th June 2021 14:00:00


RESOLVED: 06/05/2021 05:30 AM EST

The issue has been resolved and the servers are operating normally with email being delivered regularly again at this time.

Should you continue to have any issues, please contact our support team via LiveChat, Phone or Email/Support Ticket. You can find all our contact info at www.hostpapa.com .


UPDATE: 06/05/2021 12:15 AM EST

Our Email team has identified issues with spam filtering which causes delays with incoming emails and they are working on fixing it as soon as possible.

We will provide further updates as they become available. Thank you again for your patience.


UPDATE: 07:30 PM EST

Our Email Specialists continue to investigate the issue to resolve it as soon as possible. We are sorry for the inconvenience that this might cause you.

We will provide more updates once made available.


IDENTIFIED: 2:00 PM EST

We are experiencing issues with basic/advanced emails. This will result in some delays in email delivery. Our team is already investigating the issue.

We will provide an update once we have additional information. We are sorry for the inconvenience that this might cause you.