HP301 and HP302 Server Load Issues Thursday 27th May 2021 09:45:00


UPDATE: 11:45 PM EST

The issue has been resolved, and the servers HP301 and HP302 are now working properly.

Thank you for your patience and cooperation.


INVESTIGATING: 27/05/2021 09:45 AM EST

HP301 and HP302 are experiencing issues, and you may not be able to load services hosted on this server at this time, or they may be slower than normal.

Our Server Health Team is aware of the issue and are working to resolve it as quickly as possible. Further updates will be posted here.