HP301 Server Load Issues Wednesday 26th May 2021 09:00:00


UPDATE: 3:00 PM EST

The issue has been resolved, and the server HP301 is now working properly.

Thank you for your patience and cooperation.


INVESTIGATING: 26/05/2021 09:00 AM EST

HP301 is experiencing issues and you may not be able to load services hosted on this server at this time or they may be slower than normal.

Our Server Health Team is aware of the issue and are working to resolve it as quickly as possible. Further updates will be posted here.