Maintenance running on hp213 and hp252 Tuesday 30th April 2019 18:39:00


We are currently running maintenance on the servers hp213 and hp252, this maintenance might affect the server loading speed temporarily, we will update this page as soon as the maintenance is finished.

Update: Maintenance on hp252 has been completed and performance of accounts hosted here should be back to normal, while maintenance on hp213 is still ongoing.

Update: Our Server Health team has completed the maintenance impacting performance in our hp213 and hp252 servers. Both servers should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We appreciate your understanding and sincerely apologize for any inconvenience.