HostPapa Dashboard and Service Accessibility Issue Thursday 2nd October 2025 20:33:00


INVESTIGATING: Oct/02/2025 - 08:33 PM EST

We are currently experiencing an issue with our Hostpapa Dashboard. We are also investigating issues reported relating to website/email accessibility.

Our team is actively investigating to identify the root cause and will provide updates as soon as more information is available.

We apologize for any inconvenience this may cause and appreciate your patience as we work to resolve the issue.

RESOLVED: OCT/03/2025 - 1:10 AM EST

We are pleased to announce that the Dashboard is now fully operational. We sincerely appreciate your patience during the maintenance period.

Should you continue having issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

UPDATE: OCT/02/2025 - 11:17 PM EST

Please be advised that all HostPapa servers are fully operational currently. However, our System Engineers have identified an issue with our upstream provider that is currently impacting our Dashboard. This matter is regrettably outside of our direct control, but we have promptly notified the provider to ensure a swift resolution.

We will provide further updates as soon as all services are fully operational.

Thank you once again for your continued patience and understanding.