Temporary Outage Thursday 12th June 2025 14:38:44


INVESTIGATING: JUN/12/2025 - 2:00 PM

We’re currently experiencing an internal tools outage that is affecting our ability to troubleshoot customer issues. Our server health team is actively investigating and working to resolve the problem as quickly as possible.

At this time, support may be limited, but we encourage you to reach out again in a few minutes for assistance. You can also stay updated by checking this Status Page, where we’ll post real-time updates as we make progress toward a fix.

We sincerely appreciate your patience and understanding, and we’ll be back to full service as soon as possible!

Thank you for being a valued HostPapa customer.

RESOLVED: JUN/12/2025 - 4:30 PM

The recent service disruption was caused by a massive internet outage worldwide, which affected many providers, including us. Our team has worked diligently to restore services, and everything should now be functioning normally.

We appreciate your patience and understanding during this time. If you continue to experience any issues, please reach out to our support team. We’re happy to assist!

Thank you for being a valued HostPapa customer.