COMPLETE - MAY/27/2025 - 12:35 PM
This incident has been resolved.
We apologize for any inconvenience this may have caused you.
If you encounter any issues on your side, do not hesitate to reach out to us by phone or email.
Thanks for your patience and understanding.
UPDATE - MAY/27/2025 - 12:00 PM
A fix has been implemented, and we are monitoring the results.
UPDATE - MAY/27/2025 - 09:00 AM
We’re continuing to investigate an issue that’s preventing the LiveChat app from loading and causing chat widgets on websites to not appear. We appreciate your patience as we work to resolve this as quickly as possible.
INVESTIGATING: MAY/27/2025 - 06:15 AM
Our LiveChat system is currently experiencing some issues, and you may be unable to use it properly now. We're investigating this currently, and further updates will be provided here.
You can still reach us by phone or via a support ticket/email. Thank you for your patience and cooperation.