Backup Service Interruption Tuesday 26th November 2024 23:45:00


IDENTIFIED: NOV/26/2024 - 11:45 PM EST

We are currently experiencing an issue with our backup services. This issue affects backup access, particularly for our dedicated customers paying for this service.

Our team is aware of the issue and is working diligently to resolve it. At this time, backups in the Los Angeles region are unavailable. We understand the importance of these backups to our dedicated customers and apologize for any inconvenience this may cause.

We are investigating the cause of this issue and are working to restore service as quickly as possible. We will provide updates on our progress as more information becomes available.

Thank you for your patience and understanding.

RESOLVED: NOV/27/2024 - 1:10 PM EST

We are pleased to inform you that the issue with our backup services has been resolved. Backup access has been fully restored, and all services operate normally.

We apologize for any inconvenience this may have caused and appreciate your patience and understanding.

Thank you for your continued support.