Papamail Advanced/Basic Issues Detected Wednesday 10th April 2024 15:11:55


IDENTIFIED - April/10/2024 - 3:10 PM EDT

We encountered an issue preventing Cluster A webmail from loading. The root cause has been found and addressed.

We are monitoring to ensure everything is stable and will update once this is confirmed.

RESOLVED - Apr/10/2024 - 4:00 PM EDT

This issue of webmail access and delays is now resolved.

If you encounter any issues, do not hesitate to reach our support via chat/phone/email.

Thanks for your patience during this time!