Multiple Servers - Emergency Maintenance Thursday 4th April 2024 16:56:31


INVESTIGATING: Apr/4/2024 - 4:50 PM

We will be having emergency maintenance performed on multiple servers from Quadranet and services located on these servers may be affected and become inaccessible.

We sincerely apologize for the inconvenience caused.

Further updates will be posted once available. Thank you for your patience.

RESOLVED: APR/04/2024 - 8:00 PM EST

The emergency maintenance has been completed and the Quadranet servers are back online. We are still monitoring to ensure stability.

Should you continue to have any issues, please contact our support team via LiveChat, Phone, or Email/Support Ticket.

You can find all our contact info at www.hostpapa.com/about-hostpapa/contact.