LiveChat System is experiencing issues Tuesday 2nd April 2024 15:54:01


INVESTIGATING: Apr/02/2024 - 3:50 PM EDT

Our LiveChat system is currently experiencing some issues and you may be unable to use it properly now. We're investigating this currently and further updates will be provided here.

You can still reach us by phone or support ticket/email. Thank you for your patience and cooperation.

RESOLVED: Apr/02/2024 - 6:00 PM EDT

The issue with our LiveChat has been fixed.

If you encounter any issues on your side, do not hesitate to contact our support via phone or ticket/email.

Thank you for your comprehension and patience during this downtime.

MONITORING - Apr/02/2024 - 5:30 PM EDT

A fix has been implemented and we are monitoring the results.

IDENTIFIED: Apr/02/2024 - 4:30 PM EDT

The issue has been identified and a fix is being implemented.