8th July 2021

Basic Email Basic/Advanced outbound issues

FIXED 03:50 PM EST

This issue is now resolved, and all services are now operational.

Thank you for your patience.


INVESTIGATING - 2:30 PM EST

We are investigating an issue regarding sending emails from our Basic and Advanced email services.

Sorry for the inconvenience. We will provide more updates as they become available.