3rd May 2021

Web Hosting HP255 Server Issues

RESOLVED 21:00 EST

The server is back online and operating normally at this time.

Should you continue to experience any issues, please contact our support team via LiveChat, Phone, or Support Ticket/Email.


Server HP255 is experiencing issues at this time and is unreachable. As a result, services hosted on this server might not be accessible.

Our server health team is aware and working on the issue to have it resolved as quickly as possible.

Updates on the issue will be posted here. Sorry for the inconvenience that this has caused you. Thank you for your patience and cooperation.