4th January 2021

HostPapa Dashboard Dashboard login and Ticket system issues

UPDATE 5:00 PM EST

The dashboard login issue is fixed.

We are still performing emergency maintenance in our ticket system. We are having intermittent issues and this can affect tickets response time.

More updates will be posted as they are available. Thank you for your understanding.


UPDATE 1:55 PM EST

While investigating the dashboard login issue, our Systems admin also identified issues with our Ticket system. Both are under maintenance now.

More updates will be posted as they are available. Thank you for your understanding.


INVESTIGATING 12:40 PM EST

We are experiencing some issues with accessibility on our Dashboard. This is being looked into and is under maintenance now.

More updates will be posted as they are available. Thank you for your understanding.