25th December 2020

Web Hosting HP312 is having issues

RESOLVED: The server is functioning properly and everything is back to normal.

If you continue to experience any issues, please contact our support team.


Server HP312 is experiencing issues at this time. Our server health team is aware and working on the issue to have it resolved as quickly as possible.

Updates on the issue will be posted here. Sorry for the inconvenience that this has caused you. Thank you for your patience and cooperation.